M9188A LabVIEW G Driver

M9188A PXI D/A Converter

LabVIEW G Programming Information

This help file contains the LabVIEW G programming information for the M9188A PXI D/A Converter.

  • Introduction

  • M9188 Block Diagram

  • Programming Examples

  • Programming Reference

© Keysight Tecnologies, 2014


Introduction

Introduction to the KtM9188 LabVIEW Driver

The KtM9188 LabVIEW Driver allows you programmatic control for the M9188A PXI D/A Converter.

The Keysight M9188A is a digital/analog converter (D/A Converter) which consists of four isolated banks. Each isolated bank has four DAC channels, resulting in a total 16 DAC channels within one module. Every DAC channel is capable of supplying voltages between 0 V DC and +30 V DC at a 16-bit resolution. Each channel can also generate current between 0 mA and +20mA at a 16-bit resolution.

See Also:

  • Keysight M9188A production Web Site

  • Block diagram

  • Programming Examples

  • Programming Reference

  • KtM9188 Methods(VIs)

  • KtM9188 Attributes


M9188 Block Diagram

M9188A Block Diagram


Programming Examples

Programming Examples for the KtM9188 LabVIEW Driver

The following example programs are provided to demonstrate most features in the M9188A PXI D/A Converter. Each example VI has a front panel you can use to exercise the underlying VI functions.

  • Keysight M9188Arb

  • Keysight M9188ArbCreateFromFile

  • Keysight M9188Event

  • Keysight M9188Group

  • Keysight M9188Trigger


Keysight M9188Arb.vi

Keysight M9188Arb

This is an example of how to Configure Arbitrary data and Configure SamplingPeriod while channel still outputting.


Keysight M9188ArbCreateFromFile.vi

Keysight M9188ArbCreateFromFile

This is an example of how to Configure Arbitrary data Create from the File.


Keysight M9188Event.vi

Keysight M9188Event

This is an example of how to Set module event Destination.


Keysight M9188Group.vi

Keysight M9188Group

This is an example of how to Read Standard Waveform parameters.


Keysight M9188Trigger.vi

Keysight M9188Trigger

This is an example of how to Configure channel output.


Programming Reference

This section provides information on each of the VIs and the associated Attributes in the M9188A LabVIEW G Driver.

KtM9188 Methods(VIs)

VI Tree

Initialize

Initialize With Options

Close

Action Status

Configure

Data

Utility

KtM9188 Attributes

ARB_WAVEFORM_BURST_COUNT

ARB_WAVEFORM_PLAYBACK_MODE

ARB_WAVEFORM_SAMPLING_PERIOD

ARB_WAVEFORM_SIZE_MAX

ARB_WAVEFORM_SIZE_MIN

BOARD_REVISION

CALIBRATION_DATE

DRIVER_REVISION

DRIVER_SETUP

EVENT_DESTINATION

FPGA_REVISION

INSTRUMENT_FIRMWARE_REVISION

INSTRUMENT_MANUFACTURER

INSTRUMENT_MODEL

IO_RESOURCE_DESCRIPTOR

LOGICAL_NAME

OUTPUT_COUNT

OUTPUT_ENABLED

OUTPUT_MODE

OUTPUT_WAVEFORM

SERIAL_NUMBER

SIMULATE

SLOT_NUMBER

SPECIFIC_DRIVER_DESCRIPTION

SPECIFIC_DRIVER_REVISION

SPECIFIC_DRIVER_VENDOR

STD_WAVEFORM_AMPLITUDE

STD_WAVEFORM_DUTY_CYCLE_HIGH

STD_WAVEFORM_FREQUENCY

STD_WAVEFORM_FUNCTION

STD_WAVEFORM_OFFSET_LEVEL

STD_WAVEFORM_PHASE_SHIFT

SUPPORTED_INSTRUMENT_MODELS

SYNC_ENABLED

SYNC_MODE

SYNC_SOURCE

TRACE_ENABLED

TRIGGER_SLOPE

TRIGGER_SOURCE


Method

Keysight KtM9188 Methods (VIs)

This section provides technical and programming support for using the Keysight KtM9188 LabVIEW API VIs to develop applications.

The VIs are split into the following main topics, depending on their function:

VI Tree

Initialize

Initialize With Options

Close

Action Status

Send Software Trigger

Trigger Abort

Trigger Initiate

Set Burst Count

Set Output Enable

Set Output Mode

Set Playback Mode

Set Reference Clock Source

Set Sampling Period

Arb Waveform Create

Arb Waveform Create From File

Group Output Enable

Configure

Low Level

GetAttributeViBoolean

GetAttributeViInt32

GetAttributeViReal64

GetAttributeViString

SetAttributeViBoolean

SetAttributeViInt32

SetAttributeViReal64

SetAttributeViString

Trigger Configure

Configure Digital Output

Configure Std Waveform

Event Configure

Group Configure Std Waveform

Sync Configure

Sync Disable

Data

Get Output Enable

Get Output Mode

Get Playback Mode

Query Digital Input

Query Digital Output

Get Output Name

Get Sampling Period

Get Reference Clock Source

Get Burst Count

Utility

Error Message

Reset

Revision Query

Self-Test


VI Tree

The VI Tree displays all the user-callable VIs of the instrument driver in an organized table.

Keysight M9188.lvlib:VI Tree.vi


Initialize

Opens the I/O session to the instrument. Driver methods and properties that access the instrument are only accessible after Initialize is called. Initialize optionally performs a Reset and queries the instrument to validate the instrument model.

civrn

resource string

An IVI logical name or an instrument specific string that identifies the address of the instrument, such as a VISA resource descriptor string.

cbool

id query (Off)

Specifies whether to verify the ID of the instrument.

cbool

reset device (Off)

Specifies whether to reset the instrument.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cbool

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ci32

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cstr

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

iivrn

instrument handle out

Unique identifier for an IVI session.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ibool

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ii32

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

istr

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

Remarks

For detailed parameter usage see: Initializing the IVI-C Driver in KtM9188A IVI driver help


Initialize With Options

Opens the I/O session to the instrument. Driver methods and properties that access the instrument are only accessible after Initialize is called. Initialize optionally performs a Reset and queries the instrument to validate the instrument model.

Keysight M9188.lvlib:Initialize With Options.vi

cstr

resource name

An IVI logical name or an instrument specific string that identifies the address of the instrument, such as a VISA resource descriptor string.

cbool

id query (Off)

Specifies whether to verify the ID of the instrument.

cbool

reset device (Off)

Specifies whether to reset the instrument.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cbool

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ci32

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cstr

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cstr

option string

The user can use the OptionsString parameter to specify the initial values of certain IVI inherent attributes for the session. The format of an assignment in the OptionsString parameter is "Name=Value", where Name is one of: RangeCheck, QuerytInstrStatus, Cache, Simulate, RecordCoercions, InterchangeCheck, or DriverSetup. Value is either true or false except for DriverSetup. If the Options String parameter contains an assignment for the Driver Setup attribute, the Initialize function assumes that everything following "DriverSetup=" is part of the assignment.

iivrn

instrument handle out

Unique identifier for an IVI session.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ibool

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ii32

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

istr

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

Remarks

For detailed parameter usage see: Initializing the IVI-C Driver in KtM9188A IVI driver help


Close

Closes the I/O session to the instrument. Driver methods and properties that access the instrument are not accessible after Close is called.

civrn

instrument handle

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cbool

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ci32

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cstr

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ibool

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ii32

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

istr

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.


Action Status

Contained in this section are VIs which control the status or initiate actions within the instrument.

Send Software Trigger

Trigger Abort

Trigger Initiate

Set Burst Count

Set Output Enable

Set Output Mode

Set Playback Mode

Set Reference Clock Source

Set Sampling Period

Arb Waveform Create

Arb Waveform Create From File

Group Output Enable


Send Software Trigger

This function will put DAC enabled channel into outputing state only if the currently selected trigger source is Software. This function will also put DAC to output trigger output pulse or sample clock if Event Destination or Syncronization out is enabled.

Keysight M9188.lvlib:Send Software Trigger.vi

civrn

instrument handle

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cbool

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ci32

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cstr

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

iivrn

instrument handle out

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ibool

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ii32

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

istr

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.


Trigger Abort

If the DAC is currently waiting for a trigger to output signal, this function returns the DAC to the ignore triggers state.

Keysight M9188.lvlib:Trigger Abort.vi

civrn

instrument handle

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cbool

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ci32

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cstr

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

iivrn

instrument handle out

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ibool

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ii32

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

istr

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

Remarks

This function will put all channel into idle/off state. However, the output relay will stay connected.


Trigger Initiate

Put enabled channel into wait for a software trigger or hardware trigger input pulse. If the DAC is already waiting for a trigger, this function does nothing and returns Success.

Keysight M9188.lvlib:Trigger Initiate.vi

civrn

instrument handle

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cbool

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ci32

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cstr

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

iivrn

instrument handle out

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ibool

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ii32

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

istr

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.


Set Burst Count

The number of cycles to be output per triggered. The BurstCount is ignored if KtM9188PlaybackModeContinuous is selected. By default BurstCount is 1 and maximum is 10,000.

Keysight M9188.lvlib:Set Burst Count.vi

civrn

instrument handle

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cbool

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ci32

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cstr

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cstr

Output

The physical or virtual repeated capability identifier. Pass VI_NULL (0) if the operation does not apply to a repeated capability. You can also pass VI_NULL (0) if the device only has a single output.

ci32

BurstCount(1)

Default BurstCount is 1 and maximum is 10,000

iivrn

instrument handle out

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ibool

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ii32

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

istr

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.


Set Output Enable

This function is used to control the output state (True for "ON" and False for "Off") of the specified channel. This function will turn on the output relay only. The output will only appear when SoftwareTrigger or Initiate is executed. Set the output state to "Off" to abort the trigger-wait-state or to disable the outputting and turn off the output relay.

Keysight M9188.lvlib:Set Output Enable.vi

civrn

instrument handle

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cbool

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ci32

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cstr

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cstr

Output

The physical or virtual repeated capability identifier. Pass VI_NULL (0) if the operation does not apply to a repeated capability. You can also pass VI_NULL (0) if the device only has a single output.

cbool

Enabled (Off)

True for "ON" and False for "OFF". Default Value is False.

iivrn

instrument handle out

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ibool

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ii32

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

istr

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.


Set Output Mode

This function is to select the output mode (Voltage or Current) of the specified channel.

Keysight M9188.lvlib:Set Output Mode.vi

civrn

instrument handle

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cbool

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ci32

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cstr

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cstr

Output

The physical or virtual repeated capability identifier. Pass VI_NULL (0) if the operation does not apply to a repeated capability. You can also pass VI_NULL (0) if the device only has a single output.

ci32

OutputMode (Voltage)

Output source select. Voltage or Current for the specified output channel.

Defined Values For Parameter OutputMode :

Voltage (0) : Select output mode as voltage source.

Current (1) : Select output mode as current source.

Default Value for OutputMode is Voltage.

iivrn

instrument handle out

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ibool

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ii32

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

istr

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.


Set Playback Mode

This function specified the playback output is to be done. User can select KtM9188PlaybackModeContinuous for keep repeating the output waveform till instructed to stop or KtM9188PlaybackModeBurst to playback for specified number of cycles count.

Keysight M9188.lvlib:Set Playback Mode.vi

civrn

instrument handle

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cbool

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ci32

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cstr

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cstr

Output

The physical or virtual repeated capability identifier. Pass VI_NULL (0) if the operation does not apply to a repeated capability. You can also pass VI_NULL (0) if the device only has a single output.

ci32

PlaybackMode (Continuous)

select continuous mode or burst mode.

Defined Values For Parameter PlaybackMode :

Continuous (0) : Continuous output (Keep repeating the output cycles).

Burst (1) : Playback specified number of cycles count.

Default Value For PlaybackMode is Continuous.

iivrn

instrument handle out

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ibool

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ii32

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

istr

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.


Set Reference Clock Source

Specifies the source for 10MHz system clock ("Internal" or "PXI" or "External_IN" or "External_OUT").

Keysight M9188.lvlib:Set Reference Clock Source.vi

civrn

instrument handle

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cbool

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ci32

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cstr

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cstr

Source(Internal)

This is a string containing source of 10MHz system clock. The source can be configured to internal generated clock, through the PXI backplane or input from external. The internal 10MHz clock can also be sent through the EXT connector to other devices. Default Value is "Internal".

iivrn

instrument handle out

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ibool

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ii32

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

istr

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

Remarks

Changing reference clock source would require disabling the entire output channel.

The channel will stop output if module does not receive 10MHz system clock source.

Type of system clock source:-

"Internal" - configure module internal 10MHz oscillator as the system clock.

"PXI" - configure PXI backplane 10MHz as the system clock.

"External_IN" - configure front clock input 10MHz as the system clock.

"External_OUT" - configure to output module internal 10MHz to front clock.


Set Sampling Period

The sample period is the time between two datapoints of a waveform. It is configured in microseconds and can be a value between 2us to 512us in 2us steps.

Keysight M9188.lvlib:Set Sampling Period.vi

civrn

instrument handle

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cbool

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ci32

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cstr

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cstr

Output

The physical or virtual repeated capability identifier. Pass VI_NULL (0) if the operation does not apply to a repeated capability. You can also pass VI_NULL (0) if the device only has a single output.

ci32

SamplingPeriod(2)

Valid value between 2us to 512us in 2us steps. Default Value is 2us.

iivrn

instrument handle out

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ibool

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ii32

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

istr

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.


Arb Waveform Create

Download floating-point values from 0 to 30 (voltage) or 0 to 0.02 (Current) into volatile memory to specified output channel. You can download from 1 to 1,000,000 points per channel (1MSamples).

Keysight M9188.lvlib:Arb Waveform Create.vi

civrn

instrument handle

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cbool

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ci32

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cstr

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cstr

Output

The physical or virtual repeated capability identifier. Pass VI_NULL (0) if the operation does not apply to a repeated capability. You can also pass VI_NULL (0) if the device only has a single output.

ci32

ValBufferSize

Number of elements in Val.

c1ddbl

Val

The size of array must not exceed 1,000,000.

cdbl

Numeric

iivrn

instrument handle out

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ibool

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ii32

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

istr

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.


Arb Waveform Create From File

Load the arbitrary waveform from file to specified output channel.

Keysight M9188.lvlib:Arb Waveform Create From File.vi

civrn

instrument handle

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cbool

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ci32

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cstr

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cstr

Output

The physical or virtual repeated capability identifier. Pass VI_NULL (0) if the operation does not apply to a repeated capability. You can also pass VI_NULL (0) if the device only has a single output.

cstr

Name

This is a string containing path and name of the file to be loaded.

cdbl

Size

The number of data points in the data array.

iivrn

instrument handle out

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ibool

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ii32

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

istr

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

Remarks

The file format is as follows:

  • Each line consists of a real number, indicating the voltage/current level.

  • Comma is required at the end of each line.

  • It is only accepts the first column real number data of the CSV file.


Group Output Enable

Enable/disable the relay output state (True for "ON" and False for "Off") of the specified channel group. The signal output will only appear when Initiate and SoftwareTrigger are executed if the output relays of the specified channel group state are "ON".

Keysight M9188.lvlib:Group Output Enable.vi

civrn

instrument handle

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cbool

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ci32

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cstr

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ci32

ChannelGroup (Channel Group All)

Channel group "All" to select "Channels 1 to 16", "1to4" to select "Channels 1 to 4", "5to8"to select "Channels 5 to 8", "9to12" to select "Channels 9 to 12" and "13to16" to select "Channels 13 to 16".

Defined Values For Parameter ChannelGroup :

Channel Group All (0) : Configures module for all 16 channels.

Channel Group 1to4 (1) : Configures module for 1 to 4 channels.

Channel Group 5to8 (2) : Configures module for 5 to 8 channels.

Channel Group 9to12 (3) : Configures module for 9 to 12 channels.

Channel Group1 3to16 (4) : Configures module for 1 to 16 channels.

c1dbool

Enable(False)

Array of Boolean values to set the output state. True for "ON" and False for "OFF".

cbool

Boolean

iivrn

instrument handle out

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ibool

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ii32

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

istr

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.


Configure

Configuration VIs

Contained in this section are VIs which are used to configure the instrument.

Low Level

GetAttributeViBoolean

GetAttributeViInt32

GetAttributeViReal64

GetAttributeViString

SetAttributeViBoolean

SetAttributeViInt32

SetAttributeViReal64

SetAttributeViString

Trigger Configure

Configure Digital Output

Configure Std Waveform

Event Configure

Group Configure Std Waveform

Sync Configure

Sync Disable


Low Level

Configuration \ Lowe-level VIs

Contained in this section are VIs which are used to access the low-level operations of the instrument.

GetAttributeViBoolean

GetAttributeViInt32

GetAttributeViReal64

GetAttributeViString

SetAttributeViBoolean

SetAttributeViInt32

SetAttributeViReal64

SetAttributeViString


GetAttributeViBoolean

Gets a Boolean attribute from the instrument driver.

The following Attributes are supported:

  • OUTPUT_ENABLED

  • SIMULATE

  • SYNC_ENABLED

  • TRACE_ENABLED

civrn

instrument handle

This control returns an Instrument Handle that is used in all subsequent function calls to differentiate between different sessions of this instrument driver.

Notes:

(1) Each time this function is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cbool

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ci32

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cstr

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cstr

RepCapIdentifier

If the attribute applies to a repeated capability, the user passes a physical or virtual repeated capability identifier. Otherwise, the user passes VI_NULL or an empty string. For attributes requiring nested repeated capabilities, enter the names separated by a colon as in: "Window1:Trace2".

cu32

AttributeID

Selects which attribute will be accessed. Following attributes are supported :

  • OUTPUT_ENABLED : This property is used to control the output state (True for "On" and False for "Off") of the specified output channel. This function will turn on the output relay only. The output will only appear when Initiate and SoftwareTrigger are executed. Set the output state to "Off" to abort the trigger-wait-state or to disable the outputting and turn off the output relay.Default Value is False.

  • SIMULATE : If True, the driver does not perform I/O to the instrument, and returns simulated values for output parameters.

  • SYNC_ENABLED : -READ ONLY- Get the synchronization operation state (True for "ON" and False for "OFF") of the specified module.

  • TRACE_ENABLED : If true, output trace log of all driver calls to an XML file using a unique file name based on date and time in the same directory as the application executable accessing the driver OR as specified using tracing options when initializing the driver. See remarks below for tracing options information. The log file may be viewed in your web browser. If enabled, driver trace and additional IO events may also be viewed in the IO Monitor utility of Keysight IO Libraries 16.0 or newer.

Remarks:
You may also enable tracing, specify a file name and path, and additional trace options when initializing the driver. For complete information on Initialize tracing options see the 'DriverSetup' section on the Instantiating the IVI-COM Driver page in KtM9188A IVI driver help.

iivrn

instrument handle out

This control returns an Instrument Handle that is used in all subsequent function calls to differentiate between different sessions of this instrument driver.

Notes:

(1) Each time this function is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ibool

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ii32

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

istr

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ibool

AttributeValue

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.


GetAttributeViInt32

Gets an Int32 attribute from the instrument driver.

The following Attributes are supported:

  • ARB_WAVEFORM_BURST_COUNT

  • ARB_WAVEFORM_PLAYBACK_MODE

  • ARB_WAVEFORM_SAMPLING_PERIOD

  • ARB_WAVEFORM_SIZE_MAX

  • ARB_WAVEFORM_SIZE_MIN

  • OUTPUT_COUNT

  • OUTPUT_MODE

  • OUTPUT_WAVEFORM

  • SLOT_NUMBER

  • STD_WAVEFORM_FUNCTION

  • SYNC_MODE

  • TRIGGER_SLOPE

civrn

instrument handle

This control returns an Instrument Handle that is used in all subsequent function calls to differentiate between different sessions of this instrument driver.

Notes:

(1) Each time this function is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cbool

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ci32

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cstr

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cstr

RepCapIdentifier

If the attribute applies to a repeated capability, the user passes a physical or virtual repeated capability identifier. Otherwise, the user passes VI_NULL or an empty string. For attributes requiring nested repeated capabilities, enter the names separated by a colon as in: "Window1:Trace2".

cu32

AttributeID

Selects which attribute will be accessed. Following attributes are supported :

  • ARB_WAVEFORM_BURST_COUNT : Specifies the number of cycles to be output per triggered. Default Value is 1.

Remarks:
BurstCount is ignored if KtM9188PlaybackModeContinuous is selected.
Min = 1 (Default)
Max = 10,000

  • ARB_WAVEFORM_PLAYBACK_MODE : Specifies the playback mode (Continuous (0) or Burst (1)).Default Value is Continuous(0).

Remarks:
Default = Continuous

  • ARB_WAVEFORM_SAMPLING_PERIOD : Specifies the sampling period of the data points. The sampling period is defined as timeframe between 2 data points of a waveform. Default Value is 2.

Remarks:
Min = 2us (default)
Max =512us
Step size = 2us

  • ARB_WAVEFORM_SIZE_MAX : -READ ONLY- Indicates the maximum number of points the module allows in an arbitrary waveform.

  • ARB_WAVEFORM_SIZE_MIN : -READ ONLY- Indicates the minimum number of points the module allows in an arbitrary waveform.

  • OUTPUT_COUNT : -READ ONLY- This property determines the number of outputs channel available.

  • OUTPUT_MODE : Specifies the output mode (Voltage (0) or Current (1) ) of the specified channel.

  • OUTPUT_WAVEFORM : -READ ONLY- Get the output waveform(Standard (0) or Arbitrary (1) waveform) of the specified channel.

  • SLOT_NUMBER : -READ ONLY- Returns the slot number of the card.

  • STD_WAVEFORM_FUNCTION : Set or get the standard waveform output function (DC (0), Sine(1), Square(2) or Triangle(3)) of the specified channel.

Remarks:
Default = DC

  • SYNC_MODE : -READ ONLY- Gets the mode the module is operating. It can be Master or a Slave.

  • TRIGGER_SLOPE : Sets or Gets the edge of the hardware trigger input pulse. Edge can be either Positive (0) or Negative (1). Default Value is Positive(0).

iivrn

instrument handle out

This control returns an Instrument Handle that is used in all subsequent function calls to differentiate between different sessions of this instrument driver.

Notes:

(1) Each time this function is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ibool

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ii32

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

istr

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ii32

AttributeValue

Returns the current value of the property. The user must specify the address of a variable that has the same data type as the property.


GetAttributeViReal64

Gets a Real64 attribute from the instrument driver.

The following Attributes are supported:

  • STD_WAVEFORM_AMPLITUDE

  • STD_WAVEFORM_DUTY_CYCLE_HIGH

  • STD_WAVEFORM_FREQUENCY

  • STD_WAVEFORM_OFFSET_LEVEL

  • STD_WAVEFORM_PHASE_SHIFT

civrn

instrument handle

This control returns an Instrument Handle that is used in all subsequent function calls to differentiate between different sessions of this instrument driver.

Notes:

(1) Each time this function is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cbool

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ci32

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cstr

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cstr

RepCapIdentifier

If the attribute applies to a repeated capability, the user passes a physical or virtual repeated capability identifier. Otherwise, the user passes VI_NULL or an empty string. For attributes requiring nested repeated capabilities, enter the names separated by a colon as in: "Window1:Trace2".

cu32

AttributeID

Selects which attribute will be accessed. Following attributes are supported :

  • STD_WAVEFORM_AMPLITUDE : The Peak-to-peak voltage or current of the Sine, Square and Triangle waveform output by specified channel. When output function is set to DC/Static, this is the value of voltage or current level.

Remarks:
Default = 0 V or 0A
DC Voltage Range: 0 to 30V
DC Current range: 0 to 20mA
AC Voltage Range: Voffset + Vpp/2 ≤ 30V and Voffset - Vpp/2 ≥ 0
AC Current Range: IOffset + Ipp/2 ≤ 20mA and IOffset - Ipp/2 ≥ 0

  • STD_WAVEFORM_DUTY_CYCLE_HIGH : This property is to set the duty cycle when function is set to output Square waveform. The valid value is 20% to 80%.

Remarks:
Default = 50 %
Only applies when Function set to Square waveform.

  • STD_WAVEFORM_FREQUENCY : This property is to select the frequency output of Sine, Square or Triangle waveform by specified channel.

Remarks:
If user selects DC output function, these parameters will be ignored.
Default = 1KHz
Min = 1Hz
Max = 50KHz

  • STD_WAVEFORM_OFFSET_LEVEL : Specifies the dc offset level of the Sine, Square and Triangle waveform output by specified channel. When output function is set to DC/Static, this attribute does not affect output.

Remarks:
If user selects DC output function, these parameters will be ignored.
Default = 0V or 0A
AC Voltage Range: Voffset + Vpp/2 ≤ 30V and Voffset - Vpp/2 ≥ 0
AC Current Range: IOffset + Ipp/2 ≤ 20mA and IOffset - Ipp/2 ≥ 0

  • STD_WAVEFORM_PHASE_SHIFT : Specifies the output Sine, Square and Triangle waveform phase shift by specified channel. When output function is set to DC/Static, this attribute does not affect output.

Remarks:
If user selects DC output function, these parameters will be ignored.
Default = 0 degree
Range -360 to 360 degree

iivrn

instrument handle out

This control returns an Instrument Handle that is used in all subsequent function calls to differentiate between different sessions of this instrument driver.

Notes:

(1) Each time this function is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ibool

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ii32

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

istr

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

idbl

AttributeValue

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.


GetAttributeViString

Gets a String attribute from the instrument driver.

The following Attributes are supported:

  • BOARD_REVISION

  • CALIBRATION_DATE

  • DRIVER_REVISION

  • DRIVER_SETUP

  • EVENT_DESTINATION

  • FPGA_REVISION

  • INSTRUMENT_FIRMWARE_REVISION

  • INSTRUMENT_MANUFACTURER

  • INSTRUMENT_MODEL

  • IO_RESOURCE_DESCRIPTOR

  • LOGICAL_NAME

  • SERIAL_NUMBER

  • SPECIFIC_DRIVER_DESCRIPTION

  • SPECIFIC_DRIVER_REVISION

  • SPECIFIC_DRIVER_VENDOR

  • SUPPORTED_INSTRUMENT_MODELS

  • SYNC_SOURCE

  • TRIGGER_SOURCE

civrn

instrument handle

This control returns an Instrument Handle that is used in all subsequent function calls to differentiate between different sessions of this instrument driver.

Notes:

(1) Each time this function is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cbool

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ci32

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cstr

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cstr

RepCapIdentifier

If the attribute applies to a repeated capability, the user passes a physical or virtual repeated capability identifier. Otherwise, the user passes VI_NULL or an empty string. For attributes requiring nested repeated capabilities, enter the names separated by a colon as in: "Window1:Trace2".

cu32

AttributeID

Selects which attribute will be accessed. Following attributes are supported :

  • BOARD_REVISION : -READ ONLY- Returns the PCB version.

  • CALIBRATION_DATE : -READ ONLY- Returns the calibration date from EEPROM.

  • DRIVER_REVISION : -READ ONLY- Returns the fundamental driver revision

  • DRIVER_SETUP : -READ ONLY- The driver setup string. It is either specified in the Configuration Store or passed in the OptionString parameter of the Initialize function. Driver setup is empty if the driver is not initialized.

  • EVENT_DESTINATION : This is a string containing hardware trigger output pulse ("OFF" or "EXT" or "PXI<n>"). "PXI<n>" can be either one of the PXI trigger bus PXI0-PXI7.Default Value is "OFF".

Remarks:
If the specified destination value is other than "OFF", the driver will automatically sets the Trigger Source to "Software" before setting the destination value.
The output pulse only appears immediately after SoftwareTrigger is applied.

  • FPGA_REVISION : -READ ONLY- Returns the FPGA firmware version.

  • INSTRUMENT_FIRMWARE_REVISION : -READ ONLY- The firmware revision reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the firmware revision, a string is returned that explains the condition.

  • INSTRUMENT_MANUFACTURER : -READ ONLY- The name of the manufacturer reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the name of the manufacturer, a string is returned that explains the condition. Manufacturer is limited to 256 bytes.

  • INSTRUMENT_MODEL : -READ ONLY- The model number or name reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the model number or name, a string is returned that explains the condition. Model is limited to 256 bytes.

  • IO_RESOURCE_DESCRIPTOR : -READ ONLY- The resource descriptor specifies the connection to a physical device. It is either specified in the Configuration Store or passed in the ResourceName parameter of the Initialize function. It is empty if the driver is not initialized.

  • LOGICAL_NAME : -READ ONLY- Logical Name identifies a driver session in the Configuration Store. If Logical Name is not empty, the driver was initialized from information in the driver session. If it is empty, the driver was initialized without using the Configuration Store.

  • SERIAL_NUMBER : -READ ONLY- The instrument serial number.

  • SPECIFIC_DRIVER_DESCRIPTION : -READ ONLY- Returns a brief description of the IVI specific driver. The string that this attribute returns contains a maximum of 256 bytes including the NUL byte.

  • SPECIFIC_DRIVER_REVISION : -READ ONLY- Returns version information about the IVI specific driver. The string that this attribute returns contains a maximum of 256 bytes including the NUL byte.

  • SPECIFIC_DRIVER_VENDOR : -READ ONLY- Returns the name of the vendor that supplies the IVI specific driver. The string that this attribute returns contains a maximum of 256 bytes including the NUL byte.

  • SUPPORTED_INSTRUMENT_MODELS : -READ ONLY- A comma-separated list of instrument models that the IVI specific driver can control. The string does not include an abbreviation for the manufacturer if it is the same for all models.

  • SYNC_SOURCE : -READ ONLY- Gets the string containing hardware base sample clock ("OFF" or "EXT" or "PXI<n>"). "PXI<n>" can be either one of the eight PXI trigger bus PXI0-PXI7. Synchronization must occur on the same connection, for example, if the "EXT" line is used, one module will be set to Master that sends the sampling clock signal, the other will be set to Slave to receive the sample clock on the same line.

  • TRIGGER_SOURCE : Sets or Gets the string containing hardware trigger input pulse ("Software" or "EXT" or "PXI<n>"or "PXI Star"). While setting, "PXI<n>" can be either one, or multiple lines, expressed as "PXI2 + PXI4 + PXI5". If the specified source value is other than "Software", the driver automatically sets the Event Destination to "OFF" before setting the source value.Default Value is "Software".

Remarks:
Apply Trigger Initiate to put DAC into wait for trigger state, the channel will waits for a trigger pulse from the source specified with this attribute. When a trigger occurs, the channel will output the signal as per settings.
When the source is "Software", the output signal only appears immediately after SoftwareTrigger is applied.
All the channels output will be OFF (Enabled property is set to False) and the Event Destination is set to "OFF", when changing the source parameter from "Software" to "EXT" or "PXI<N>" or "PXI STAR".

iivrn

instrument handle out

This control returns an Instrument Handle that is used in all subsequent function calls to differentiate between different sessions of this instrument driver.

Notes:

(1) Each time this function is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ibool

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ii32

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

istr

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

istr

AttributeValue

The buffer in which the VI returns the current value of the property. Can be VI_NULL (0) if AttributeValueBufferSize is 0.


SetAttributeViBoolean

Sets a Boolean attribute from the instrument driver.

The following Attributes are supported:

  • OUTPUT_ENABLED

  • SIMULATE

  • TRACE_ENABLED

civrn

instrument handle

This control returns an Instrument Handle that is used in all subsequent function calls to differentiate between different sessions of this instrument driver.

Notes:

(1) Each time this function is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cbool

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ci32

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cstr

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cstr

RepCapIdentifier

If the attribute applies to a repeated capability, the user passes a physical or virtual repeated capability identifier. Otherwise, the user passes VI_NULL or an empty string. For attributes requiring nested repeated capabilities, enter the names separated by a colon as in: "Window1:Trace2".

cbool

AttributeValue (Off)

The value to which to set the attribute.

cu32

AttributeID

Selects which attribute will be accessed. Following attributes are supported :

  • OUTPUT_ENABLED : This property is used to control the output state (True for "On" and False for "Off") of the specified output channel. This function will turn on the output relay only. The output will only appear when Initiate and SoftwareTrigger are executed. Set the output state to "Off" to abort the trigger-wait-state or to disable the outputting and turn off the output relay.Default Value is False.

  • SIMULATE : If True, the driver does not perform I/O to the instrument, and returns simulated values for output parameters.

  • TRACE_ENABLED : If true, output trace log of all driver calls to an XML file using a unique file name based on date and time in the same directory as the application executable accessing the driver OR as specified using tracing options when initializing the driver. See remarks below for tracing options information. The log file may be viewed in your web browser. If enabled, driver trace and additional IO events may also be viewed in the IO Monitor utility of Keysight IO Libraries 16.0 or newer.

Remarks:
You may also enable tracing, specify a file name and path, and additional trace options when initializing the driver. For complete information on Initialize tracing options see the 'DriverSetup' section on the Instantiating the IVI-COM Driver page in KtM9188A IVI driver help.

iivrn

instrument handle out

This control returns an Instrument Handle that is used in all subsequent function calls to differentiate between different sessions of this instrument driver.

Notes:

(1) Each time this function is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ibool

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ii32

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

istr

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.


SetAttributeViInt32

Sets an Int32 attribute from the instrument driver.

The following Attributes are supported:

  • ARB_WAVEFORM_BURST_COUNT

  • ARB_WAVEFORM_PLAYBACK_MODE

  • ARB_WAVEFORM_SAMPLING_PERIOD

  • OUTPUT_MODE

  • STD_WAVEFORM_FUNCTION

  • TRIGGER_SLOPE

civrn

instrument handle

This control returns an Instrument Handle that is used in all subsequent function calls to differentiate between different sessions of this instrument driver.

Notes:

(1) Each time this function is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cbool

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ci32

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cstr

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cstr

RepCapIdentifier

If the attribute applies to a repeated capability, the user passes a physical or virtual repeated capability identifier. Otherwise, the user passes VI_NULL or an empty string. For attributes requiring nested repeated capabilities, enter the names separated by a colon as in: "Window1:Trace2".

ci32

AttributeValue

The value to which to set the attribute.

For OUTPUT_MODE, valid values are:

OUTPUT_MODE_VOLTAGE (0) : Select output mode as voltage source.

OUTPUT_MODE_CURRENT (1) : Select output mode as current source.

For STD_WAVEFORM_FUNCTION, valid values are:

STD_WAVEFORMDC (0) : Select DC output.

STD_WAVEFORM_SINE (1) : Select Sine output waveform.

STD_WAVEFORM_SQUARE (2) : Select Square output waveform.

STD_WAVEFORM_TRIANGLE (3) : Select Triangle output waveform.

For ARB_WAVEFORM_PLAYBACK_MODE, valid values are:

PLAYBACK_MODE_CONTINUOUS (0) : Continuous output (Keep repeating the output cycles).

PLAYBACK_MODE_BURST (1) : Playback specified number of cycles count.

For TRIGGER_SLOPE, valid values are:

TRIGGER_SLOPE_POSITIVE (0) : Configures trigger on the positive slope.

TRIGGER_SLOPE_NEGATIVE (1) : Configures trigger on the negative slope.

For SYNC_MODE, valid values are:

SYNC_MODE_SLAVE (0) : Configures module to be slave in synchronization.

SYNC_MODE_MASTER (1) : Configures module to be master in synchronization.

For OUTPUT_WAVEFORM, valid values are:

OUTPUT_WAVEFORM_STD (0)

OUTPUT_WAVEFORM_ARB (1)

cu32

AttributeID

Selects which attribute will be accessed. Following attributes are supported :

  • ARB_WAVEFORM_BURST_COUNT : Specifies the number of cycles to be output per triggered.Default Value is 1.

Remarks:
BurstCount is ignored if KtM9188PlaybackModeContinuous is selected.
Min = 1 (Default)
Max = 10,000

  • ARB_WAVEFORM_PLAYBACK_MODE : Specifies the playback mode.Default Value is Continuous(0).

Remarks:
Default = Continuous

  • ARB_WAVEFORM_SAMPLING_PERIOD : Specifies the sampling period of the data points. The sampling period is defined as timeframe between 2 data points of a waveform.Default Value is 2.

Remarks:
Min = 2us (default)
Max =512us
Step size = 2us

  • OUTPUT_MODE : Specifies the output mode (Voltage or Current) of the specified channel.

  • STD_WAVEFORM_FUNCTION : Set or get the standard waveform output function (DC, Sine, Square or Triangle) of the specified channel.

Remarks:
Default = DC

  • TRIGGER_SLOPE : Sets or Gets the edge of the hardware trigger input pulse. Edge can be either Positive or Negative.Default Value is Positive(0).

iivrn

instrument handle out

This control returns an Instrument Handle that is used in all subsequent function calls to differentiate between different sessions of this instrument driver.

Notes:

(1) Each time this function is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ibool

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ii32

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

istr

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.


SetAttributeViReal64

Sets a Real64 attribute from the instrument driver.

The following Attributes are supported:

  • STD_WAVEFORM_AMPLITUDE

  • STD_WAVEFORM_DUTY_CYCLE_HIGH

  • STD_WAVEFORM_FREQUENCY

  • STD_WAVEFORM_OFFSET_LEVEL

  • STD_WAVEFORM_PHASE_SHIFT

civrn

instrument handle

This control returns an Instrument Handle that is used in all subsequent function calls to differentiate between different sessions of this instrument driver.

Notes:

(1) Each time this function is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cbool

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ci32

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cstr

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cstr

RepCapIdentifier

If the attribute applies to a repeated capability, the user passes a physical or virtual repeated capability identifier. Otherwise, the user passes VI_NULL or an empty string. For attributes requiring nested repeated capabilities, enter the names separated by a colon as in: "Window1:Trace2".

cdbl

AttributeValue

The value to which to set the attribute.

cu32

AttributeID

Selects which attribute will be accessed. Following attributes are supported :

  • STD_WAVEFORM_AMPLITUDE : The Peak-to-peak voltage or current of the Sine, Square and Triangle waveform output by specified channel. When output function is set to DC/Static, this is the value of voltage or current level.

Remarks:
Default = 0 V or 0A
DC Voltage Range: 0 to 30V
DC Current range: 0 to 20mA
AC Voltage Range: Voffset + Vpp/2 ≤ 30V and Voffset - Vpp/2 ≥ 0
AC Current Range: IOffset + Ipp/2 ≤ 20mA and IOffset - Ipp/2 ≥ 0

  • STD_WAVEFORM_DUTY_CYCLE_HIGH : This property is to set the duty cycle when function is set to output Square waveform. The valid value is 20% to 80%.

Remarks:
Default = 50 %
Only applies when Function set to Square waveform.

  • STD_WAVEFORM_FREQUENCY : This property is to select the frequency output of Sine, Square or Triangle waveform by specified channel.

Remarks:
If user selects DC output function, these parameters will be ignored.
Default = 1KHz
Min = 1Hz
Max = 50KHz

  • STD_WAVEFORM_OFFSET_LEVEL : Specifies the dc offset level of the Sine, Square and Triangle waveform output by specified channel. When output function is set to DC/Static, this attribute does not affect output.

Remarks:
If user selects DC output function, these parameters will be ignored.
Default = 0V or 0A
AC Voltage Range: Voffset + Vpp/2 ≤ 30V and Voffset - Vpp/2 ≥ 0
AC Current Range: IOffset + Ipp/2 ≤ 20mA and IOffset - Ipp/2 ≥ 0

  • STD_WAVEFORM_PHASE_SHIFT : Specifies the output Sine, Square and Triangle waveform phase shift by specified channel. When output function is set to DC/Static, this attribute does not affect output.

Remarks:
If user selects DC output function, these parameters will be ignored.
Default = 0 degree
Range -360 to 360 degree

iivrn

instrument handle out

This control returns an Instrument Handle that is used in all subsequent function calls to differentiate between different sessions of this instrument driver.

Notes:

(1) Each time this function is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ibool

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ii32

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

istr

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.


SetAttributeViString

Sets a String attribute from the instrument driver.

The following Attributes are supported:

  • EVENT_DESTINATION

  • TRIGGER_SOURCE

civrn

instrument handle

This control returns an Instrument Handle that is used in all subsequent function calls to differentiate between different sessions of this instrument driver.

Notes:

(1) Each time this function is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cbool

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ci32

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cstr

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cstr

RepCapIdentifier

If the attribute applies to a repeated capability, the user passes a physical or virtual repeated capability identifier. Otherwise, the user passes VI_NULL or an empty string. For attributes requiring nested repeated capabilities, enter the names separated by a colon as in: "Window1:Trace2".

cstr

AttributeValue

The value to which to set the attribute.

cu32

AttributeID

Selects which attribute will be accessed. Following attributes are supported :

  • EVENT_DESTINATION : This is a string containing hardware trigger output pulse ("OFF" or "EXT" or "PXI<n>"). "PXI<n>" can be either one of the PXI trigger bus PXI0-PXI7.Default Value is "OFF".

Remarks:
If the specified destination value is other than "OFF", the driver will automatically sets the Trigger Source to "Software" before setting the destination value.
The output pulse only appears immediately after SoftwareTrigger is applied.

  • TRIGGER_SOURCE : Sets or Gets the string containing hardware trigger input pulse ("Software" or "EXT" or "PXI<n>"or "PXI Star"). While setting, "PXI<n>" can be either one, or multiple lines, expressed as "PXI2 + PXI4 + PXI5". If the specified source value is other than "Software", the driver automatically sets the Event Destination to "OFF" before setting the source value.Default Value is "Software".

Remarks:
Apply Trigger Initiate to put DAC into wait for trigger state, the channel will waits for a trigger pulse from the source specified with this attribute. When a trigger occurs, the channel will output the signal as per settings.
When the source is "Software", the output signal only appears immediately after SoftwareTrigger is applied.
All the channels output will be OFF (Enabled property is set to False) and the Event Destination is set to "OFF", when changing the source parameter from "Software" to "EXT" or "PXI<N>" or "PXI STAR".

iivrn

instrument handle out

This control returns an Instrument Handle that is used in all subsequent function calls to differentiate between different sessions of this instrument driver.

Notes:

(1) Each time this function is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ibool

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ii32

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

istr

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.


Trigger Configure

Configure the trigger settings of the module.

Keysight M9188.lvlib:Trigger Configure.vi

civrn

instrument handle

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cbool

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ci32

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cstr

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cstr

Source(Software)

This is a string containing hardware trigger input pulse ("Software" or "EXT" or "PXI<n>" or "PXI STAR"). "PXI<n>" can be either one, or multiple lines, expressed as "PXI2 + PXI4 + PXI5". If the specified source value is other than "Software", the driver automatically sets the Event Destination to "OFF" before setting the source value.Default Value is "Software".

ci32

Slope (Positive)

Trigger Slope is used to configure the trigger edge. It can either be Positive or Negative.

Defined Values For Parameter Slope :

Positive (0) : Configures trigger on the positive slope.

Negative (1) : Configures trigger on the negative slope.

Default Value For Slope is Positive.

iivrn

instrument handle out

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ibool

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ii32

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

istr

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

Remarks

Apply Trigger Initiate to put DAC into wait for trigger state, the channel will waits for a trigger pulse from the source specified with this attribute. When a trigger occurs, the channel will output the signal as per settings.

When the source is "Software", the output signal only appears immediately after SoftwareTrigger is applied.

All the channels output will be OFF (Enabled property is set to False) and the Event Destination is set to "OFF", when changing the source parameter from "Software" to "EXT" or "PXI<N>" or "PXI STAR".


Configure Digital Output

Configures all 4 designated output bits (Bit 0 - Bit 3). Each element of the Settings array contains the setting for a digital output line, beginning with in the lowest order element of the array.

Keysight M9188.lvlib:Configure Digital Output.vi

civrn

instrument handle

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cbool

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ci32

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cstr

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ci32

SettingsBufferSize

Number of elements in Settings.

c1di32

Settings

A 4 element array of output bit settings, with bit 0 in the lowest order element. Allowable settings for the Output State values are: Sink = 0 (driven low) or Source = 1 (driven high).

Default values are [0,0,0,0].

ci32

Numeric

iivrn

instrument handle out

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ibool

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ii32

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

istr

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.


Configure Std Waveform

This method configures the voltage or current mode, standard waveform output function, amplitude, offset level, phase shift and preset frequency for the specified output channel. The specified settings will not be placed onto the output until the specified Trigger occurs.

Keysight M9188.lvlib:Configure Std Waveform.vi

civrn

instrument handle

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cbool

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ci32

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cstr

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cstr

Output

The physical or virtual repeated capability identifier. Pass VI_NULL (0) if the operation does not apply to a repeated capability. You can also pass VI_NULL (0) if the device only has a single output.

ci32

OutputMode (Voltage)

Output source select. Voltage or Current for the specified output channel.

Defined Values For Parameter OutputMode :

Voltage (0) : Select output mode as voltage source.

Current (1) : Select output mode as current source.

Default Value For OutputMode is Voltage.

ci32

Function (dc)

The output functions for the specified output channel.

Defined Values For Parameter Function :

dc (0) : Select DC output.

Sine (1) : Select Sine output waveform.

Square (2) : Select Square output waveform.

Triangle (3) : Select Triangle output waveform.

Default Value For Function is dc.

cdbl

Amplitude(0)

In DC/Static mode, amplitude represents the voltage or current level. In AC mode the amplitude is the output peak-to-peak value of voltage or current. DC Voltage Range: 0 to 30V; DC Current range: 0 to 20mA;AC Voltage Range: Voffset + Vpp/2 <= 30V and Voffset - Vpp/2 => 0;AC Current Range: IOffset + Ipp/2 <= 20mA and IOffset - Ipp/2 => 0.Default Value is 0.

cdbl

OffsetLevel(0)

The output offset level. Voltage Range: Voffset + Vpp/2 <= 30V and Voffset - Vpp/2 => 0; Current Range: IOffset + Ipp/2 <= 20mA and IOffset - Ipp/2 => 0. Apply for AC waveform output. Apply for AC waveform output.Default Value is 0.

cdbl

PhaseShift(0)

Phase output of the waveform, in degree. Range -360 to 360 degree. Apply for AC waveform output.Default Value is 0.

cdbl

Frequency(1000)

Frequency of the standard waveform. The range is 1Hz to 50 kHz. Apply for AC waveform output.Default Value is 1000.

cdbl

DutyCycleHigh(50)

Only applies when Function set to Square waveform. Valid values are 20% to 80%.Default Value is 50.

iivrn

instrument handle out

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ibool

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ii32

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

istr

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

Remarks

If user changes Output Function or Mode on a channel, the output level or waveform is set to zero till trigger is received.

The specified Amplitude must be appropriate for the specified Mode at that same location in the array (i.e. a level of 12 is OK for Voltage, but illegal for Current).

Amplitude, OffsetLevel, PhaseShift and Frequency is applied for waveform output function only. If user select waveform output function, all these parameters must be a valid value. If user selects DC output function, these parameters will be ignored, except for Amplitude which will represent the dc level.


Event Configure

Configures the hardware or PXI bus trigger output pulse.

Keysight M9188.lvlib:Event Configure.vi

civrn

instrument handle

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cbool

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ci32

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cstr

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cstr

Destination(OFF)

This is a string containing hardware trigger output pulse ("OFF" or "EXT" or "PXI<n>"). "PXI<n>" can be either one of the PXI trigger bus PXI0-PXI7.Default value is "OFF".

iivrn

instrument handle out

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ibool

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ii32

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

istr

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

Remarks

If the specified destination value is other than "OFF", the driver will automatically sets the Trigger Source to "Software" before setting the destination value.

The output pulse only appears immediately after SoftwareTrigger is applied.


Group Configure Std Waveform

Configures the voltage or current mode, standard waveform output function, amplitude, offset level, phase shift and preset frequency for the specified channel group. The specified settings will not be placed into the outputs until the specified Trigger occurs.

Keysight M9188.lvlib:Group Configure Std Waveform.vi

civrn

instrument handle

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cbool

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ci32

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cstr

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ci32

ChannelGroup (Channel Group All)

Channel group "All" to select "Channels 1 to 16", "1to4" to select "Channels 1 to 4", "5to8"to select "Channels 5 to 8", "9to12" to select "Channels 9 to 12" and "13to16" to select "Channels 13 to 16".

Defined Values For Parameter ChannelGroup :

Channel Group All (0) : Configures module for all 16 channels.

Channel Group 1to4 (1) : Configures module for 1 to 4 channels.

Channel Group 5to8 (2) : Configures module for 5 to 8 channels.

Channel Group 9to12 (3) : Configures module for 9 to 12 channels.

Channel Group1 3to16 (4) : Configures module for 1 to 16 channels.

ci32

OutputMode (Voltage)

Output mode select. Voltage or Current for the channel group.

Defined Values For Parameter OutputMode :

Voltage (0) : Select output mode as voltage source.

Current (1) : Select output mode as current source.

Default Value for OutputMode is Voltage.

ci32

Function (dc)

The output functions for the specific group.

Defined Values For Parameter Function :

dc (0) : Select DC output.

Sine (1) : Select Sine output waveform.

Square(2) : Select Square output waveform.

Triangle (3) : Select Triangle output waveform.

Default Value for Function is dc.

ci32

AmplitudeBufferSize

Number of elements in Amplitude.

c1ddbl

Amplitude(0)

In DC/Static mode, amplitude represents the voltage or current level. In AC mode the amplitude is the output peak-to-peak value of voltage or current. DC Voltage Range: 0 to 30V; DC Current range: 0 to 20mA;AC Voltage Range: Voffset + Vpp/2 <= 30V and Voffset - Vpp/2 => 0;AC Current Range: IOffset + Ipp/2 <= 20mA and IOffset - Ipp/2 => 0.Default value is 0.

cdbl

Numeric

ci32

OffsetLevelBufferSize

Number of elements in OffsetLevel.

c1ddbl

OffsetLevel(0)

The output offset level. Voltage Range: Voffset + Vpp/2 <= 30V and Voffset - Vpp/2 => 0; Current Range: IOffset + Ipp/2 <= 20mA and IOffset - Ipp/2 => 0. Apply for AC waveform output.Default Value is 0.

cdbl

Numeric

ci32

PhaseShiftBufferSize

Number of elements in PhaseShift.

c1ddbl

PhaseShift(0)

Phase output of the waveform, in degree. Range -360 to 360 degree. Apply for AC waveform output.Default Value is 0.

cdbl

Numeric

ci32

FrequencyBufferSize

Number of elements in Frequency.

c1ddbl

Frequency(1000)

Frequency of the standard waveform. The range is 1Hz to 50kHz. Apply for AC waveform output.Default Value is 1000.

cdbl

Numeric

ci32

DutyCycleHighBufferSize

Number of elements in DutyCycleHigh.

c1ddbl

DutyCycleHigh(50)

Only applies when Function set to Square waveform. Valid values are 20% to 80%.Default Value is 50.

cdbl

Numeric

iivrn

instrument handle out

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ibool

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ii32

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

istr

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

Remarks

User must provide Function array and Amplitude array of same size, and it must at least as large as the number of channels being configured (that would be either 4 or 16 elements).

The specified Amplitude must be appropriate for the specified Mode at that same location in the array (i.e. a level of 12 is OK for Voltage, but illegal for Current).

Amplitude, OffsetLevel, PhaseShift and Frequency is applied for waveform output function only. If user select waveform output function, all these parameters must be a valid value. If user selects DC output function, these parameters will be ignored, except for Amplitude which will represent the dc level.


Sync Configure

Configures the module to enable/disable the synchronizing function of two modules and to set a module to be Master (sending of sample clock) or a Slave (receiving of sample clock). This also configures which of the trigger lines will be used for this synchronizing function whether PXI<n> or EXT.

Keysight M9188.lvlib:Sync Configure.vi

civrn

instrument handle

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cbool

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ci32

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cstr

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ci32

Mode (Slave)

Configure module to Master or Slave. Master will be sending the sample clock and the Slave will be receiving it.

Defined Values For Parameter Mode :

Slave (0) : Configures module to be slave in synchronization.

Master (1) : Configures module to be master in synchronization.

Default Value is Slave.

cstr

Source(EXT)

This is a string containing hardware base sample clock ("EXT" or "PXI<n>"). "PXI<n>" can be either one of the eight PXI trigger bus PXI0-PXI7.

cbool

Enable (Off)

When Enable set to True, the state will be "ON" and the module is ready for multi-module synchronization operation. When set to False the synchronizing operation of the module is "OFF" or disabled.

iivrn

instrument handle out

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ibool

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ii32

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

istr

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.


Sync Disable

This method disables module synchronization operation either it is Master or Slave mode.

Keysight M9188.lvlib:Sync Disable.vi

civrn

instrument handle

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cbool

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ci32

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cstr

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

iivrn

instrument handle out

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ibool

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ii32

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

istr

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.


Data VIs

Contained in this section are VIs which are used to collect data from the instrument.

Get Output Enable

Get Output Mode

Get Playback Mode

Query Digital Input

Query Digital Output

Get Output Name

Get Sampling Period

Get Reference Clock Source

Get Burst Count


Get Output Enable

This function is used to read back the output state (True for "ON" and False for "Off") of the specified channel.

Keysight M9188.lvlib:Get Output Enable.vi

civrn

instrument handle

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cbool

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ci32

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cstr

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cstr

Output

The physical or virtual repeated capability identifier. Pass VI_NULL (0) if the operation does not apply to a repeated capability. You can also pass VI_NULL (0) if the device only has a single output.

iivrn

instrument handle out

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ibool

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ii32

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

istr

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ibool

Enabled

True for "ON" and False for "OFF".


Get Output Mode

This function is to read back the output mode (Voltage or Current) of the specified channel.

Keysight M9188.lvlib:Get Output Mode.vi

civrn

instrument handle

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cbool

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ci32

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cstr

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cstr

Output

The physical or virtual repeated capability identifier. Pass VI_NULL (0) if the operation does not apply to a repeated capability. You can also pass VI_NULL (0) if the device only has a single output.

iivrn

instrument handle out

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ibool

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ii32

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

istr

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ii32

OutputMode

Output source select. Voltage or Current for the specified output channel.

Returned values of OutputMode are :

0 : Voltage source : Select output mode as voltage source.

1 : Current source. Select output mode as current source.


Get Playback Mode

This function return playback output mode of specified channel. KtM9188PlaybackModeContinuous is to keep repeating the output waveform till instructed to stop or KtM9188PlaybackModeBurst is to playback for specified number of cycles count.

Keysight M9188.lvlib:Get Playback Mode.vi

civrn

instrument handle

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cbool

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ci32

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cstr

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cstr

Output

The physical or virtual repeated capability identifier. Pass VI_NULL (0) if the operation does not apply to a repeated capability. You can also pass VI_NULL (0) if the device only has a single output.

iivrn

instrument handle out

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ibool

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ii32

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

istr

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ii32

PlaybackMode

Return continuous mode or burst mode.

Returned values of PlaybackMode are :

0 : Continuous output (Keep repeating the output cycles).

1 : Playback specified number of cycles count.


Query Digital Input

Reads the state of all 4 designated input bits (Bit 0 - Bit 3) and returns an array of those states, beginning with bit 0 in the lowest order array element.

Keysight M9188.lvlib:Query Digital Input.vi

civrn

instrument handle

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cbool

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ci32

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cstr

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ci32

ValBufferSize

Number of elements in Val.

iivrn

instrument handle out

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ibool

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ii32

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

istr

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

i1di32

Val

A 4 element array of input bit states. State of each bit will be one of the following values: 0 = Input State Low; 1 = Input State High.

ii32

Numeric

ii32

ValActualSize

Actual number of elements in Val.


Query Digital Output

Returns all 4 output bit Settings, with bit 0 in the lowest order array element.

Keysight M9188.lvlib:Query Digital Output.vi

civrn

instrument handle

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cbool

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ci32

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cstr

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ci32

ValBufferSize

Number of elements in Val.

iivrn

instrument handle out

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ibool

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ii32

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

istr

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

i1di32

Val

The value returned in each array element will be either 0 or 1 where 0 = Sink (driven low) and 1 = Source (driven high).

ii32

Numeric

ii32

ValActualSize

Actual number of elements in Val.


Get Output Name

Returns the output name that corresponds to the one-based index that the user specifies.

Keysight M9188.lvlib:Get Output Name.vi

civrn

instrument handle

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cbool

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ci32

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cstr

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ci32

Index

A one-based index that defines which name to return.

ci32

NameBufferSize

Number of elements in Name.

iivrn

instrument handle out

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ibool

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ii32

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

istr

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

istr

Name

Specifies the buffer into which the function returns the name that corresponds to the index the user specifies. The caller may pass VI_NULL for this parameter if the buffer size parameter is 0.


Get Sampling Period

This function read back the sample period between two data points of a waveform.

Keysight M9188.lvlib:Get Sampling Period.vi

civrn

instrument handle

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cbool

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ci32

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cstr

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cstr

Output

The physical or virtual repeated capability identifier. Pass VI_NULL (0) if the operation does not apply to a repeated capability. You can also pass VI_NULL (0) if the device only has a single output.

iivrn

instrument handle out

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ibool

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ii32

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

istr

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ii32

SamplingPeriod

Valid value between 2us to 512us in 2us steps.


Get Reference Clock Source

Return the source of the 10MHz system clock of the module.

Keysight M9188.lvlib:Get Reference Clock Source.vi

civrn

instrument handle

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cbool

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ci32

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cstr

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ci32

SourceBufferSize

Number of elements in Source.

iivrn

instrument handle out

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ibool

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ii32

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

istr

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

istr

Source

This is a string containing source of 10MHz system clock.

Remarks

The channel will stop output if module does not receive 10MHz system clock source.

Type of system clock source:-

"Internal" - configure module internal 10MHz oscillator as the system clock.

"PXI" - configure PXI backplane 10MHz as the system clock.

"External_IN" - configure front clock input 10MHz as the system clock.

"External_OUT" - configure to output module internal 10MHz to front clock.


Get Burst Count

This function read back the number of burst count of the specified channel. By default BurstCount is 1 and maximum is 10,000.

Keysight M9188.lvlib:Get Burst Count.vi

civrn

instrument handle

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cbool

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ci32

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cstr

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cstr

Output

The physical or virtual repeated capability identifier. Pass VI_NULL (0) if the operation does not apply to a repeated capability. You can also pass VI_NULL (0) if the device only has a single output.

iivrn

instrument handle out

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ibool

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ii32

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

istr

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ii32

BurstCount

Default BurstCount is 1 and maximum is 10,000


Utility

Utility VIs

Contained in this section are VIs which are used to control various functions of the instrument.

Error Message

Reset

Revision Query

Self-Test


Error Message

Translates the error return value from an IVI driver function to a user-readable string. The user should pass a buffer with at least 256 bytes for the ErrorMessage parameter.

Keysight M9188.lvlib:Error Message.vi

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cbool

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ci32

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cstr

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

civrn

instrument handle

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

ci32

Error Code

Instrument driver status code.

iivrn

instrument handle out

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ibool

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ii32

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

istr

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

istr

Error Message

Instrument driver error message.


Reset

Places the instrument in a known state and configures instrument options on which the IVI specific driver depends (for example, enabling/disabling headers).

civrn

instrument handle

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cbool

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ci32

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cstr

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

iivrn

instrument handle out

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ibool

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ii32

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

istr

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

Remarks

The following table shows which settings are affected by reset.

Item | Power-on/Reset State
Reference Clock Source | Internal
Digital Output Settings | [0,0,0,0]
Trigger Source | Software
Trigger Slope | Positive
Event Destination | OFF
Sync Mode | Slave
Sync Source | EXT
Sync Enabled | FALSE
Outputs |
Output Mode | Voltage
Output Waveform | Standard Waveform
Output Enabled | FALSE
Outputs - Standard Waveform |
Function | DC
Amplitude | 0 V
OffsetLevel | 0 V
PhaseShift | 0 Degree
Frequency | 1000 Hz
DutyCyclehigh | 50 Percent
Outputs - Arbitrary Waveform |
Burst Count | 1
Playback Mode | Continuous
Sampling Period | 2 us


Revision Query

Retrieves revision information from the instrument.

Keysight M9188.lvlib:Revision Query.vi

civrn

instrument handle

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cbool

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ci32

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cstr

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

iivrn

instrument handle out

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

istr

instrument driver revision

Returns the revision of the IVI specific driver, which is the value held in the Specific Driver Revision attribute. Refer to the Specific Driver Revision attribute for more information.

istr

firmware revision

Returns the firmware revision of the instrument, which is the value held in the Instrument Firmware Revision attribute. Refer to the Instrument Firmware Revision attribute for more information.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ibool

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ii32

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

istr

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.


Self-Test

Performs an instrument self test, waits for the instrument to complete the test, and queries the instrument for the results. If the instrument passes the test, TestResult is zero and TestMessage is 'Self test passed'.

civrn

instrument handle

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cbool

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ci32

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cstr

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

iivrn

instrument handle out

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

ii16

self test result

The numeric result from the self test operation. 0 = no error (test passed)

istr

self-test message

The self test status message

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ibool

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ii32

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

istr

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.


Attribute

KtM9188 Attributes

This section provides technical and programming support for using the keysight KtM9188 LabVIEW API VIs to develop applications.

The Attributes are values used by certain of the Vis to configure and return data about the state of the instrument.

ARB_WAVEFORM_BURST_COUNT

ARB_WAVEFORM_PLAYBACK_MODE

ARB_WAVEFORM_SAMPLING_PERIOD

ARB_WAVEFORM_SIZE_MAX

ARB_WAVEFORM_SIZE_MIN

BOARD_REVISION

CALIBRATION_DATE

DRIVER_REVISION

DRIVER_SETUP

EVENT_DESTINATION

FPGA_REVISION

INSTRUMENT_FIRMWARE_REVISION

INSTRUMENT_MANUFACTURER

INSTRUMENT_MODEL

IO_RESOURCE_DESCRIPTOR

LOGICAL_NAME

OUTPUT_COUNT

OUTPUT_ENABLED

OUTPUT_MODE

OUTPUT_WAVEFORM

SERIAL_NUMBER

SIMULATE

SLOT_NUMBER

SPECIFIC_DRIVER_DESCRIPTION

SPECIFIC_DRIVER_REVISION

SPECIFIC_DRIVER_VENDOR

STD_WAVEFORM_AMPLITUDE

STD_WAVEFORM_DUTY_CYCLE_HIGH

STD_WAVEFORM_FREQUENCY

STD_WAVEFORM_FUNCTION

STD_WAVEFORM_OFFSET_LEVEL

STD_WAVEFORM_PHASE_SHIFT

SUPPORTED_INSTRUMENT_MODELS

SYNC_ENABLED

SYNC_MODE

SYNC_SOURCE

TRACE_ENABLED

TRIGGER_SLOPE

TRIGGER_SOURCE


ARB_WAVEFORM_BURST_COUNT

Specifies the number of cycles to be output per triggered.

Data Type

cu32

Unsigned Integer 32

Remarks:
BurstCount is ignored if KtM9188PlaybackModeContinuous is selected.
Min = 1 (Default)
Max = 10,000


ARB_WAVEFORM_PLAYBACK_MODE

Specifies the playback mode.

Data Type

cu32

Unsigned Integer 32

Supported Values

0x00000000 | Continuous mode.
0x00000001 | Burst mode.

Remarks:
Default = Continuous


ARB_WAVEFORM_SAMPLING_PERIOD

Specifies the sampling period of the data points. The sampling period is defined as timeframe between 2 data points of a waveform.

Data Type

cu32

Unsigned Integer 32

Remarks:
Min = 2us (default)
Max =512us
Step size = 2us


ARB_WAVEFORM_SIZE_MAX

-READ ONLY- Indicates the maximum number of points the module allows in an arbitrary waveform.

Data Type

cu32

Unsigned Integer 32


ARB_WAVEFORM_SIZE_MIN

-READ ONLY- Indicates the minimum number of points the module allows in an arbitrary waveform.

Data Type

cu32

Unsigned Integer 32


BOARD_REVISION

-READ ONLY- Returns the PCB version.

Data Type

istr

String


CALIBRATION_DATE

-READ ONLY- Returns the calibration date from EEPROM.

Data Type

istr

String


DRIVER_REVISION

-READ ONLY- Returns the fundamental driver revision

Data Type

istr

String


DRIVER_SETUP

-READ ONLY- The driver setup string. It is either specified in the Configuration Store or passed in the OptionString parameter of the Initialize function. Driver setup is empty if the driver is not initialized.

Data Type

istr

String


EVENT_DESTINATION

This is a string containing hardware trigger output pulse ("OFF" or "EXT" or "PXI<n>"). "PXI<n>" can be either one of the PXI trigger bus PXI0-PXI7.Default Value is "OFF".

Data Type

istr

String

Supported Values

'OFF' | Event is turned off
'EXT' | Send Event out to EXT TRIG front connector
'PXI<n>' | Send Event out to PXI Bus where <n> is the number from 0 to 7

Remarks:
If the specified destination value is other than "OFF", the driver will automatically sets the Trigger Source to "Software" before setting the destination value.
The output pulse only appears immediately after SoftwareTrigger is applied.


FPGA_REVISION

-READ ONLY- Returns the FPGA firmware version.

Data Type

istr

String


INSTRUMENT_FIRMWARE_REVISION

-READ ONLY- The firmware revision reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the firmware revision, a string is returned that explains the condition.

Data Type

istr

String


INSTRUMENT_MANUFACTURER

-READ ONLY- The name of the manufacturer reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the name of the manufacturer, a string is returned that explains the condition. Manufacturer is limited to 256 bytes.

Data Type

istr

String


INSTRUMENT_MODEL

-READ ONLY- The model number or name reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the model number or name, a string is returned that explains the condition. Model is limited to 256 bytes.

Data Type

istr

String


IO_RESOURCE_DESCRIPTOR

-READ ONLY- The resource descriptor specifies the connection to a physical device. It is either specified in the Configuration Store or passed in the ResourceName parameter of the Initialize function. It is empty if the driver is not initialized.

Data Type

istr

String


LOGICAL_NAME

-READ ONLY- Logical Name identifies a driver session in the Configuration Store. If Logical Name is not empty, the driver was initialized from information in the driver session. If it is empty, the driver was initialized without using the Configuration Store.

Data Type

istr

String


OUTPUT_COUNT

-READ ONLY- This property determines the number of outputs channel available.

Data Type

cu32

Unsigned Integer 32


OUTPUT_ENABLED

This property is used to control the output state (True for "On" and False for "Off") of the specified output channel. This function will turn on the output relay only. The output will only appear when Initiate and SoftwareTrigger are executed. Set the output state to "Off" to abort the trigger-wait-state or to disable the outputting and turn off the output relay.Default Value is False.

Data Type

Boolean

Supported Values

True | On
False | Off


OUTPUT_MODE

Specifies the output mode of the specified channel.

Data Type

cu32

Unsigned Integer 32

Supported Values

0x00000000 | Voltage mode
0x00000001 | Current mode


OUTPUT_WAVEFORM

-READ ONLY- Get the output waveform of the specified channel.

Data Type

cu32

Unsigned Integer 32

Supported Values

0x00000000 | Standard waveform
0x00000001 | Arbitrary waveform


SERIAL_NUMBER

-READ ONLY- The instrument serial number.

Data Type

istr

String


SIMULATE

If True, the driver does not perform I/O to the instrument, and returns simulated values for output parameters.

Data Type

Boolean

Supported Values

True | The intrument simulates values for output parameters.
False | The instrument operates normally.


SLOT_NUMBER

-READ ONLY- Returns the slot number of the card.

Data Type

cu32

Unsigned Integer 32


SPECIFIC_DRIVER_DESCRIPTION

-READ ONLY- Returns a brief description of the IVI specific driver. The string that this attribute returns contains a maximum of 256 bytes including the NUL byte.

Data Type

istr

String


SPECIFIC_DRIVER_REVISION

-READ ONLY- Returns version information about the IVI specific driver. The string that this attribute returns contains a maximum of 256 bytes including the NUL byte.

Data Type

istr

String


SPECIFIC_DRIVER_VENDOR

-READ ONLY- Returns the name of the vendor that supplies the IVI specific driver. The string that this attribute returns contains a maximum of 256 bytes including the NUL byte.

Data Type

istr

String


STD_WAVEFORM_AMPLITUDE

The Peak-to-peak voltage or current of the Sine, Square and Triangle waveform output by specified channel. When output function is set to DC/Static, this is the value of voltage or current level.

Data Type

idbl

Real64

Remarks:
Default = 0 V or 0A
DC Voltage Range: 0 to 30V
DC Current range: 0 to 20mA
AC Voltage Range: Voffset + Vpp/2 ≤ 30V and Voffset - Vpp/2 ≥ 0
AC Current Range: IOffset + Ipp/2 ≤ 20mA and IOffset - Ipp/2 ≥ 0


STD_WAVEFORM_DUTY_CYCLE_HIGH

This property is to set the duty cycle when function is set to output Square waveform. The valid value is 20% to 80%.

Data Type

idbl

Real64

Remarks:
Default = 50 %
Only applies when Function set to Square waveform.


STD_WAVEFORM_FREQUENCY

This property is to select the frequency output of Sine, Square or Triangle waveform by specified channel.

Data Type

idbl

Real64

Remarks:
If user selects DC output function, these parameters will be ignored.
Default = 1KHz
Min = 1Hz
Max = 50KHz


STD_WAVEFORM_FUNCTION

Set or get the standard waveform output function of the specified channel.

Data Type

cu32

Unsigned Integer 32

Supported Values

0x00000000 | DC
0x00000001 | Sinusoidal waveform
0x00000002 | Square waveform
0x00000003 | Triangle waveform

Remarks:
Default = DC


STD_WAVEFORM_OFFSET_LEVEL

Specifies the dc offset level of the Sine, Square and Triangle waveform output by specified channel. When output function is set to DC/Static, this attribute does not affect output.

Data Type

idbl

Real64

Remarks:
If user selects DC output function, these parameters will be ignored.
Default = 0V or 0A
AC Voltage Range: Voffset + Vpp/2 ≤ 30V and Voffset - Vpp/2 ≥ 0
AC Current Range: IOffset + Ipp/2 ≤ 20mA and IOffset - Ipp/2 ≥ 0


STD_WAVEFORM_PHASE_SHIFT

Specifies the output Sine, Square and Triangle waveform phase shift by specified channel. When output function is set to DC/Static, this attribute does not affect output.

Data Type

idbl

Real64

Remarks:
If user selects DC output function, these parameters will be ignored.
Default = 0 degree
Range -360 to 360 degree


SUPPORTED_INSTRUMENT_MODELS

-READ ONLY- A comma-separated list of instrument models that the IVI specific driver can control. The string does not include an abbreviation for the manufacturer if it is the same for all models.

Data Type

istr

String


SYNC_ENABLED

-READ ONLY- Get the synchronization operation state (True for "ON" and False for "OFF") of the specified module.

Data Type

Boolean

Supported Values

True | Synchronization operation is enabled on the instrument.
False | Synchronization operation is not enabed on the instrument.


SYNC_MODE

-READ ONLY- Gets the mode the module is operating. It can be Master or a Slave.

Data Type

cu32

Unsigned Integer 32

Supported Values

0x00000000 | The module is configured as Master.
0x00000001 | The module is configured as Slave.


SYNC_SOURCE

-READ ONLY- Gets the string containing hardware base sample clock ("OFF" or "EXT" or "PXI<n>"). "PXI<n>" can be either one of the eight PXI trigger bus PXI0-PXI7. Synchronization must occur on the same connection, for example, if the "EXT" line is used, one module will be set to Master that sends the sampling clock signal, the other will be set to Slave to receive the sample clock on the same line.

Data Type

istr

String

Supported Values

'OFF' | Synchronization operation is not enabled
'EXT' | Synchronization operation through EXT TRIG front connector
'PXI<n>' | Synchronization operation through PXI Bus where <n> is the number from 0 to 7


TRACE_ENABLED

If true, output trace log of all driver calls to an XML file using a unique file name based on date and time in the same directory as the application executable accessing the driver OR as specified using tracing options when initializing the driver. See remarks below for tracing options information. The log file may be viewed in your web browser. If enabled, driver trace and additional IO events may also be viewed in the IO Monitor utility of Keysight IO Libraries 16.0 or newer.

Data Type

Boolean

Supported Values

True | Trace operation is enabled.
False | Trace operation is not enabled.

Remarks:
You may also enable tracing, specify a file name and path, and additional trace options when initializing the driver. For complete information on Initialize tracing options see the 'DriverSetup' section on the Instantiating the IVI-COM Driver page in KtM9188A IVI driver help.


TRIGGER_SLOPE

Sets or Gets the edge of the hardware trigger input pulse. Edge can be either Positive or Negative. Default Value is Positive.

Data Type

cu32

Unsigned Integer 32

Supported Values

0x00000000 | Positive slope
0x00000001 | negative slope


TRIGGER_SOURCE

Sets or Gets the string containing hardware trigger input pulse ("Software" or "EXT" or "PXI<n>"or "PXI Star"). While setting, "PXI<n>" can be either one, or multiple lines, expressed as "PXI2 + PXI4 + PXI5". If the specified source value is other than "Software", the driver automatically sets the Event Destination to "OFF" before setting the source value.Default Value is "Software".

Data Type

istr

String

Supported Values

'Software' | Software trigger
'EXT' | Trigger source from EXT TRIG front connector
'PXI<n>' | Trigger source from PXI Busses where <n> is the number from 0 to 7
'PXI Star' | Trigger source from PXI Star

Remarks:
Apply Trigger Initiate to put DAC into wait for trigger state, the channel will waits for a trigger pulse from the source specified with this attribute. When a trigger occurs, the channel will output the signal as per settings.
When the source is "Software", the output signal only appears immediately after SoftwareTrigger is applied.
All the channels output will be OFF (Enabled property is set to False) and the Event Destination is set to "OFF", when changing the source parameter from "Software" to "EXT" or "PXI<N>" or "PXI STAR".


IVI Error Converter

This VI converts error codes from IVI instrument drivers to standard LabVIEW error codes. If an error is detected the VI builds the appropriate error cluster that is readable by one of the error handlers supplied with LabVIEW.

Keysight M9188.lvlib:IVI Error Converter.vi

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cbool

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ci32

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

cstr

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ci32

IVI error code (0)

Error code returned from an IVI instrument driver operation.

cu32

instrument handle

The instrument handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

Default Value: None

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ibool

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

ii32

code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

istr

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

iu32

instrument handle out

The instrument handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

Default Value: None